Service Disruption – Authentication Issues
Resolved
Jun 12 at 11:31am HDT
The upstream networking issues reported earlier appear to be fully resolved. Our systems are now operating normally, and all API endpoints and the dashboard should be fully accessible again.
While we’ll continue to monitor closely for any lingering effects, we believe the incident has been resolved.
Thank you for your patience and understanding throughout the disruption.
Affected services
Admin Portal
Student Portal
Updated
Jun 12 at 11:19am HDT
We’re continuing to monitor the outage reported by our upstream networking provider. While intermittent issues are still affecting our API endpoints and dashboard, we’re seeing steady improvements and a clear downward trend in error rates.
Based on current progress, we expect services to return to full stability soon, though some users may continue to experience temporary disruptions.
You can follow updates from our upstream provider here: https://www.cloudflarestatus.com/incidents/25r9t0vz99rp
We appreciate your continued patience and will provide more updates as the recovery continues.
Affected services
Admin Portal
Student Portal
Updated
Jun 12 at 09:42am HDT
Update: We’ve confirmed that the issue is tied to a broader outage affecting Google Cloud services, which is impacting multiple downstream platforms. We're continuing to monitor the situation closely.
Thank you for your patience and understanding.
Affected services
Admin Portal
Student Portal
Created
Jun 12 at 09:33am HDT
We’re currently experiencing authentication issues due to an outage affecting one of our upstream service providers. As a result, you may be unable to log in or access parts of the platform that require authentication.
To clarify: this issue is not with Housing.Cloud systems, but with a third-party provider we depend on for authentication services. We’re actively working to get in touch with them and will provide updates as soon as we have more information.
Thanks for your patience and understanding.
Affected services
Admin Portal
Student Portal