Back to overview
Degraded
Scheduled Maintenance – September 24 at 11 PM EST
Sep 24 at 05:29pm HDT
Affected services
Admin Portal
Student Portal
Demo page
Resolved
Sep 24 at 06:51pm HDT
Maintenance has completed successfully. Thank you for you patience!
Affected services
Created
Sep 24 at 05:29pm HDT
Housing.Cloud will be performing routine maintenance on September 24 starting at 11:00 PM EST. During this time, you may not be able to access Housing.Cloud for a short period. We’ll have things back up and running as soon as possible to minimize any disruption.
Affected services