Back to overview
Degraded

Downstream Service Degradation

Nov 20 at 08:48am HST
Affected services
Admin Portal
Student Portal

Resolved
Nov 20 at 09:55am HST

Service has been fully restored. We apologize for the inconvenience this caused. The root issue stemmed from a hardware failure on the dedicated servers used by our database provider, which led to delays in our replica databases. We redeployed fresh replicas and completed the recovery process. Everything is operating normally again.

Created
Nov 20 at 08:48am HST

We're currently seeing downstream service degradation. Our team is working with the provider to identify the cause and restore normal performance. You may experience brief periods where the system is unavailable while we shift traffic to backup services. Our provider is investigating the issue and we are monitoring closely.